System overview


SUDSA allows the user to sample or load data into Spike2 and then analyse it. The program uses an FFT to create a power against frequency histogram with user defined frequency bands. All results are recorded into a text file.





The system can also analyse a “marker” channel. The purpose of the marker channel when this script was written was to mark when an eye was looking on or off target and so will, in the course of this manual, be treated as such. 





When the data is to be analysed, the user will be required to select a region of data to process; this will be referred to as the analysis region. Once this analysis is completed, the analysis region will then be split into smaller “epochs” and the same analysis done on each of these.





Getting started


Once Spike2 has been successfully installed on your machine (see “Installation” in the Spike2 manual), do the following:





Step 1. Use File Manager to copy sudsa1.s2s from the diskette into c:\spike2\scripts. 


Step 2. Run the Spike2 program.


Step 3. Pull down the File menu and click on Open.


Step 4. In the Open window there is a List files of type window, click on Script Files (*.s2s).


Step 5. Click on the Scripts directory in the Directories window.


Step 6. Click on sudsa1.s2s in the File window and then on OK.


Step 7. Pull down the Script menu and click on Run Script.


Step 8. Click on SUDSA1.S2S and you are ready to go.


Step 9. From now on, if you quit from the script and wish to return to it, go back to Step 7.





If you wish to view the text of the script, pull down the Window menu, click on Show and then on SUDSA.S2S.


Once the script is loaded


When the script first starts you should see a mostly empty screen with a "toolbar" at the top with the following buttons:


Quit	Quits the script.


Analysis	Analyses the data.


Configuration	Opens the Configuration window.


Load File	Loads a data file.


Start Sampling	Starts sampling (at which point this button will change to Stop Sampling).


Set Bands	Allows the user to enter the frequency bands they wish for analysis.


Configuring the system





If you press the Configuration button, the configuration dialog opens with the following fields:





Number of frequency bands


Enter the number of user defined frequency bands that you require. If this is changed, you will be asked to specify the frequency ranges for each band.





Analysis region size


Enter the size of the interval you wish to analyse, in seconds.





Number of epochs


Once the analysis region has been analysed, the script will divide this region into the specified number of “epochs”. These epochs will all be of equal length, partitioning the region. Analysis will then be performed on each epoch.





FFT resolution


Spike2 performs an FFT on the data to be analysed. This generates an initial spectrum of power against frequency with the frequency axis divided into “FFT Resolution”/2 bands of equal size. The script then uses this information to generate a histogram with the required user defined frequency bands. (The initial FFT histogram is not shown to the user, only the resulting one with the user defined bands.)





FFT stands for Fast Fourier Transform, which is a mathematical method for transforming a sequence of numbers representing a time series (in our case a waveform) into a new sequence that approximates to the frequency content. To perform the FFT, Spike2 must have at least as many data points as the resolution of the FFT.





WARNING: The analysis region will be split into smaller epochs, each of which must have enough data points to perform the FFT. Suppose you are sampling at 100 Hz and you want to analyse an analysis region of 30 sec which will be spilt into 6x5 sec epochs. In each epoch you will have 500 data points, so your FFT resolution must be less then 500. (For more information see “Power Spectrum” in the Spike2 manual).





Marker codes for off/on target


This script has been designed to analyse a marker channel as well as analogue channels. It assumes that there is a marker channel for recording when an eye is looking on target or off target. When the eye changes from being off target to being on target, the marker code for on target will appear in the marker channel at that time. Similarly with the off target marker. (Note: the script assumes that for any period where the eye does not change from being on target to off target, or vice versa, no markers will appear).





When the script analyses an epoch, it calculates the percentage of time that the eye was on target as a proportion of the length of the epoch.





Remove the DC offset


The script contains a function to remove any DC offset from the waveforms which are to be analysed. This function comes into operation during analysis. It does not alter the actual waveforms, but merely the resulting power spectra. The function is enabled by checking the box.


Setting the user defined frequency bands


If you press the Set Bands button on the toolbar, a window appears prompting you to edit the frequency ranges to include in each band. Enter the frequency ranges you wish to have as your user defined frequency bands.





If you try to enter frequencies which are more than half of the sampling frequency of your data channels, the FFT will not register them and the bands will be empty. (For more information on the FFT and frequency ranges see “Power Spectrum” in the Spike2 manual).





Note: bands are not allowed to overlap.


Sampling


To sample data, first pull down the Sample menu from the main menu bar at the top of the screen. then click on Sampling Configuration. Set up the sampling configuration as required. For information on how to do this, consult “Sampling Data” in the Spike2 manual.





When your channels are all set up correctly, press the Sample Start button in the toolbar. This button will then change to Sample Stop and sampling will commence. Information on how to change the scale of the axes and the view of the channels is documented in the “Getting Started” section of the Spike2 manual.





When you are ready to stop sampling, press the Sample Stop button in the toolbar. The configuration window will appear for confirmation of settings. Once OK has been clicked, the main data window will redraw with the entire recording on it. Two cursors will appear on the screen labelled Start and End. Start will be at zero time and End will be one analysis region length after that.





Loading data from disk


To load previously recorded data from disk, press the Load File button in the toolbar and select a data file. When a file has been loaded the Start and End cursors appear and you can start data analysis. Loading a data file or sampling new data closes all data files which were open beforehand.


Moving the cursors


When data is present in the system, two cursors labelled Start and End appear. You use these cursors to select the region for analysis.





To change the position of the cursors, move the mouse to the Start cursor and the mouse icon should change. Click and hold the mouse button down and move the cursor to the desired starting position. The End cursor cannot be dragged in the same way, but will always stay one analysis region length in front of the Start cursor. To change the position of the End cursor without changing the Start cursor, click on the Configuration button and change the analysis region length.


Analysing the data


When the required analysis region has been selected with the two cursors, and the configuration has been set up as required, press the Analyse button in the toolbar. You are asked:





1.	To set the channels to analyse. You can choose any number of channels from the list provided.


2.	To set which marker channel you want the on/off target analysis to be performed on.


3.	To confirm or edit the start time for the analysis region.


4.	To select a channel for on-screen result display. Results from one channel are always displayed.


5.	To set the name of the text file to hold the results.





Once the script has this information it starts to analyse the data. The script analyses the entire region and identifies the epochs. A new toolbar appears with Continue and Abort buttons.





Continue	The script will analyse each epoch in turn.


Abort	Stop the analysis and return to the main toolbar.





There are three data windows displayed on screen during data analysis. The upper window shows the analysis region. When the script is analysing an interval of data, the two cursors will move to the start and end of that interval.





At the bottom left hand corner is a histogram of power against frequency (in user defined bands) of the channel selected for display .





At the bottom right corner is a table with the analysed results from the displayed channel.





To view the results file you must quit the script, pull down the File menu and click on Open. Select Text Files (*.txt) as the Type of files to list and load in your text file.


The resulting text file 


The analysed results are written to a text file from which sections can be cut and pasted into spreadsheet applications. Here is an example of such a file:





File :C:\SPIKE2\DATA\TEXT.TXT


Ep(x)=Epoch (x)	[Ep 0 = Whole analysis region]


Ch(x)=Channel (x)


P   =Power in Volts^2


%    =Percentage of power





Analysis region length 15 seconds.


3 epochs in the region each of which is of length 5.000000 seconds





(Ep0)-Whole region:	From time 10.000000 sec to 25.000000 sec


		Percentage of time On Target 53%





(Ep1)-Epoch 1:	From time 10.000000 sec to 15.000000 sec


		Percentage of time On Target 51%





(Ep2)-Epoch 2:	From time 15.000000 sec to 20.000000 sec


		Percentage of time On Target 37%





(Ep3)-Epoch 3:	From time 20.000000 sec to 25.000000 sec


		Percentage of time On Target 66%





Info    	Band 0 to 8 	Band 9 to 16 	Band 17 to 24 	Band 25 to 32 	Total


Ep0, Ch3, P	0.000003	0.000001	0.000001	0.000000	0.000005


     Ch3, %	65.470521	14.631699	12.291346	7.606434	100.000000


Ep0, Ch4, P	0.000011	0.000002	0.000002	0.000001	0.000016


     Ch4, %	67.207317	15.915326	11.027220	5.850137	100.000000


Ep0, Ch9, P	0.003796	0.000002	0.000000	0.000000	0.003798


     Ch9, %	99.925754	0.059284	0.010613	0.004348	100.000000








Ep1, Ch3, P	0.000004	0.000001	0.000001	0.000000	0.000005


     Ch3, %	70.563693	11.621194	10.657028	7.158085	100.000000


Ep1, Ch4, P	0.000006	0.000004	0.000002	0.000001	0.000013


     Ch4, %	49.271250	30.504077	12.600888	7.623785	100.000000


Ep1, Ch9, P	0.020343	0.000002	0.000000	0.000000	0.020345


     Ch9, %	99.989661	0.008125	0.001585	0.000629	100.000000





Ep2, Ch3, P	0.000002	0.000000	0.000001	0.000000	0.000004


     Ch3, %	60.207101	13.606601	14.382038	11.804260	100.000000


Ep2, Ch4, P	0.000008	0.000002	0.000002	0.000001	0.000014


     Ch4, %	59.773774	17.240576	13.519071	9.466579	100.000000


Ep2, Ch9, P	0.044341	0.000002	0.000000	0.000000	0.044344


     Ch9, %	99.994086	0.004774	0.000850	0.000291	100.000000





Ep3, Ch3, P	0.000002	0.000001	0.000001	0.000000	0.000004


     Ch3, %	56.766496	16.679198	16.816321	9.737985	100.000000


Ep3, Ch4, P	0.000009	0.000002	0.000002	0.000001	0.000014


     Ch4, %	66.446778	13.321124	12.547688	7.684410	100.000000


Ep3, Ch9, P	0.000129	0.000003	0.000000	0.000000	0.000132


     Ch9, %	97.572173	1.969754	0.340293	0.117779	100.000000





The file starts with the name of the file and a key to abbreviations used in the file. This is followed by information about the analysis region as a whole followed by the start and end times of each epoch and percentage of time on target. Ep 0 is the same as the whole analysis region and ep1-ep3 are the three epochs into which the region has been divided. Finally there is a table containing the power spectrum information. Each epoch is taken in turn and separated by a carriage return.





Within each of these blocks of information, there is the information for each channel that was chosen for analysis. Each channel takes two lines. The first line is the power in each frequency band in volts^2, the second line is the power in each frequency band as a percentage of the total power in all the shown frequency bands. (This is not necessarily the same as the total power over all frequencies, since your frequency bands may not cover the whole frequency range).





Columns in the table are separated by tab characters.





Appendix


Changing the standard settings


When SUDSA is loaded in to your computer, it will have standard settings e.g. the number of frequency bands, the FFT resolution and so on. The system will be restored to these settings each time the script is run, so you may wish to change these settings. To change the standard settings, it is necessary to change the script.





Either 


If the script has not yet been loaded into Spike2, load it as described in the first section of this manual, but do not go to the Script menu (stop after Step 6). The script should be in a window on the screen.





or


If the script is running on the computer, first quit the script by pressing the Quit button in the toolbar. The script is still loaded in the computer at this time, but is not visible. To make it visible, pull down the Window menu, click on Show and then on SUDSA1.S2S.





The text of the script should now be in front of you, in a window, on the screen.


Quite near the beginning of the script is a procedure called Settings(), the values in this procedure can be changed. When you are finished changing the script, you may save it by pulling down the File menu and clicking on Save As. You can run it by pulling down the Script menu and clicking on Run Script. (It is not necessary to save the script before running it, the changed script will stay in the computer until you close it).
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