
  

 

The CED Talker Interface Box 
 

Copyright  Cambridge Electronic Design Limited 2019 

Neither the whole nor any part of the information contained in, 
or the product described in, this guide may be adapted or 
reproduced in any material form except with the prior written 
approval of Cambridge Electronic Design Limited. 

 

1st edition (1.4) January 2019 
 

 

Published by: 

Cambridge Electronic Design Ltd, 
Technical Centre, 
139 Cambridge Road, 
Milton, 
Cambridge CB24 6AZ 
UK 

 

Telephone: +44 (0)1223 420186 
USA & Canada Toll Free 1-800-345-7794 
Web: www.ced.co.uk 
Email: info@ced.co.uk 
 

 

Trademarks and Tradenames used in this guide are 
acknowledged to be the Trademarks and Tradenames of their 
respective Companies and Corporations.



 Talker Interface Box 

2 

Table of contents ...................................................................... 2 
Introduction to the TIB ............................................................ 3 
Front and rear panels ................................................................ 4 
Sensor inputs ............................................................................ 6 
Installation ................................................................................ 8 
Using TIBTalk .......................................................................... 9 
TIBTalk commands ................................................................. 10 

Using multiple TIBs ............................................................ 12 
Using the TIB with Spike2 .................................................... 13 

Configuring sampling .......................................................... 14 
Sampling TIB data with Spike2 .......................................... 17 
Sampling rate issues ............................................................ 18 
Displaying and using TIB data ............................................ 18 
Sample timing issues ........................................................... 19 

TIB sensor device details ....................................................... 20 
The MPU9250 and MPU9150 9-axis position sensors ....... 20 
SPI interface issues – no magnetometer ............................. 21 
MPU9250 configuration ...................................................... 21 
Sampling rate limits ............................................................ 23 
The LPS22HB temperature & pressure sensor ................... 24 
LPS22 configuration ........................................................... 24 
Sampling rate limits ............................................................ 25 

Appendix 1:   TIBTalk command line options ....................... 26 
Appendix 2:   Updating the TIB firmware ............................. 28 

Table of 
contents 



 Installation and introductory user manual 

3 

The Talker Interface Box (TIB) is a simple computer system 
based on a Teensy™ 3.2 microcontroller, which can interface to 
a wide variety of sensors. You connect to a TIB via the USB 
interface of a PC running specialised software (‘TIBTalk’). 
Under the control of TIBTalk, the TIB provides information 
about itself, and provides and makes use of device 
configuration information. TIBTalk separately connects to 
CED’s Spike2 program (running on the same or another PC) 
using the Talker interface protocol, and liaises with Spike2 on 
behalf of the TIB. 

 

The end result of all this is a software and hardware system 
which provides Spike2 with one or more data channels from the 
TIB for inclusion in a sampling configuration. It supplies 
Spike2 with the necessary information to generate a 
configuration dialog used for setting TIB configuration 
parameters, which are also saved in the sampling configuration. 
During Spike2 sampling, it provides the desired channel(s) of 
data for inclusion in the data file being recorded. 

An external trigger signal, normally generated by the 1401, can 
be provided to the TIB to ensure that the start of data sampling 
is precisely timed with respect to the 1401. 

An external synchronisation cable can be used to connect the 
TIB to the 1401 being used by Spike2; this ensures absolute 
timing accuracy between the TIB data and data sampled by the 
1401. It is possible to run the TIB without synchronisation. 
Here the TIB will generate extra timing information used 
internally by Spike2 to compensate for the drift between the 
TIB and 1401 clocks. 

Introduction to 
the TIB 
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The TIB front panel holds the two ODU sockets to which the 
sensors are connected (see below for details) and a BNC trigger 
input. 
The BNC connector accepts a TTL trigger signal that optionally 
can be used to synchronise the start of TIB sampling with the 
1401. 
In order to use a triggered start to sampling you have to connect 
the Trigger in BNC to a suitable 1401 digital output and, using 
Spike2, set up the 1401 to generate a suitable trigger pulse at 
the required time. Then, still in Spike2, you must configure the 
TIB to use a triggered start to sampling, and enter the time, after 
the start of the experiment, at which the 1401 generates the 
trigger pulse. 

 

The sensor inputs, Sensor 0 and Sensor 1, accept digital data, 
either in SPI or I2C format, from a range of sensors. The range 
will be added to from time to time, according to demand and as 
new devices become available. For information on two sensors 
documented in this manual, see page 20 onwards. 

Front and rear 
panels 

Trigger in 

Sensor input 
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From left to right on the rear panel we have the fine hole used 
to press the re-program switch (above the E in the CE mark), a 
rotary switch used to set the TIB unit number, three LEDs 
indicating the TIB status, the USB type B connector used to 
connect to the host PC, and the 1401 external synchronisation 
connector. 

 

This is only used when updating the internal TIB firmware (see 
Appendix 2). 

To allow multiple TIBs on the same PC to be distinguished, the 
TIB incorporates a four-bit rotary switch used to generate the 
TIB unit number, from 0 to 15. 

These indicate TIB status. The green LED is lit whenever the 
TIB is powered-up and connected to a PC. The yellow LED 
flashes when the TIB is waiting for a start-of-sampling trigger 
and when the Flash LED command in TIBTalk is used. The red 
LED is lit if an error is detected: either that no sensor devices 
were found or when data is lost during sampling. 

The TIB is connected to the host PC using a standard USB A 
to USB B cable. 

The sync input is a standard CED1401 synchronisation 
connector which, when connected to the synchronisation socket 
on a 1401, provides the TIB with a synchronised 20 MHz clock 
signal. This ensures that data times generated by the TIB are  
accurate and do not drift with respect to times within the 1401. 

Note that the synchronisation cable is not reversible; the cable 
end that plugs into the 1401 is marked “M” for Master. No 
damage will be caused by accidentally reversing the cable, but 
the synchronisation will not work. 

The rear panel 

Re-program switch 

Rotary switch 

LEDs 

USB connection 

Sync input 
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The TIB box has two independent input channels, available on 
separate 9-way ODU connectors. Each channel has two 
separate input modes: I2C and SPI. The signals for these are 
each brought out to their own pins on the connectors. +3.3 V 
and ground are also brought out, to power the sensor 
electronics, but this should be limited to 50 mA. The diagram 
shows the pinout as seen looking at the front panel. 

 

ODU front-panel connector pinout 

ODU pin Signal Description 
1 SDA I2C data 

2 SCL I2C clock 

3 MOSI SPI serial data out from sensor 

4 ISO_GND Isolated ground 

5 ISO_Vcc Isolated +3.3V (50mA max) 

6 SCLK SPI clock 

7 NCS SPI select (active low) 

8 MISO SPI serial data in from sensor 

9 SYS_GND System ground, CAUTION 

The plug that mates with this connector is an ODU 
Medi-Snap part, ODU part number S11M07-P09MCC0-3960. 
Please note that the solder-bucket terminals are very small and 
closely-spaced, and wiring up a plug takes patience, a steady 
hand, and a soldering iron with a very fine tip. The plugs are 
available ready-wired, at extra cost. 

Sensor inputs 

Mating plug details 
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The sensor inputs of the TIB box are electrically isolated from 
the Teensy™ microcontroller, from each other and from the 
host computer. This applies not only to the signals, but also to 
sensor power and ground. Thus there is no path by which 
current can flow from the sensors to the host computer. This is 
known as ‘galvanic isolation’. As a result, the host has some 
protection against accidental overvoltages from the sensors, up 
to the minimum rated breakdown voltage of the isolating 
components. These include the magnetically-coupled DC-DC 
converter, which is rated to withstand 1000 V DC for 1 second. 
This is only a stress rating; it should not be relied on under 
normal working conditions. 

See http://power.murata.com/data/power/ncl/kdc_crr1.pdf for 
further information. 

As well as being a safety feature, the isolation contributes to the 
elimination of mains-borne interference. System (i.e. non-
isolated) ground is also brought out on the sensor connectors, 
with the primary purpose of connecting the screen of the 
multicore transducer cable. Care is necessary when planning 
other uses for the system ground output, since connecting it to 
any of the sensor signals will nullify the galvanic isolation. 

In this version of the TIB, the sensor isolation is not 
designed to be compatible with medical isolation standards. 
Additional medical-standard mains isolation must be used if 
sensors connected to the TIB are to be in electrical contact 
with human subjects. 

Isolation 

http://power.murata.com/data/power/ncl/kdc_crr1.pdf�
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When you plug the TIB into a Windows PC USB port it 
initially connects as a USB serial-line device, but this 
configuration cannot be used because it does not provide 
sufficient bandwidth. The Zadig automated driver installer 
(supplied with the TIB software, or downloadable) must be 
used to change the TIB USB device drivers to more generic 
types. When you first run Zadig it will probably not show any 
available TIB devices; use Options > List All Devices to show 
them. You should then be able to find a Teensy TIB device in 
the list of available devices. Select the WinUSB driver as the 
driver to be used and click on ‘Replace driver’ to change the 
driver used for the TIB: 

 

The Zadig program will then make the necessary system 
changes (which you may have to approve) so that the generic 
WinUSB driver is used with the TIB. Depending upon your 
Windows configuration you may see two versions of the TIB, 
Interface 0 and Interface 1, in the list of available devices. In 
this case replace the driver with WinUSB for both interfaces. 

Installation 
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The TIBTalk program mediates between the TIB and Spike2. It 
can also be used to check that your TIB is properly connected 
and functioning correctly. TIBTalk is installed using a standard 
Windows installer; once TIBTalk has been installed you can run 
it by double clicking on the installed TIBTalk.exe file or desktop 
shortcut. TIBTalk will automatically search for a connected TIB 
device on the PC on which it is running. If the TIB is not 
plugged in or if TIBTalk was unable to connect to the TIB, the 
first line in the status display will show a message indicating 
this. Once TIBTalk has detected and opened a connection to the 
TIB the first line of the status display will show the successful 
connection status and TIB details while the second line will 
show the internal TIB status and what sensor devices were 
detected: 

 

The following lines will show the details of each sensor device, 
including its type and the TIB bus number and type on which it 
is connected; the TIB supports the use of both the I2C and SPI 
buses to connect to sensor devices. The final line gives details 
of the Spike2 Talker interface connection. The window area 
below the status text lines is used to display information on 
starting and stopping sampling, plus information about any 
errors or problems that might occur. 

Using TIBTalk 
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You can check that the TIB connection is working correctly 
(and that you are using the correct TIB, if you have more than 
one) by using the File > Flash activity LED command in TIBTalk 
which will cause the yellow activity LED on the TIB to flash 
for five seconds. 

Once TIBTalk is connected to the TIB it automatically starts 
looking for a talker connection to a copy of Spike2 that 
supports version 3 of the Talker interface. This revision of the 
interface is supported in Spike2 version 8.08 or later, and in 
Spike2 version 7.18 or later. TIBTalk will refuse a connection 
with earlier versions of Spike2. By default this will be a copy of 
Spike2 on the same machine as TIBTalk, but the File menu 
connection settings dialog or a TIBTalk command line 
parameter can be used to specify a different machine on the 
same local network. See Appendix 1 for details of the command 
line options that can be used with TIBTalk. 

In order to use the TIB, you will not need to do more than 
connect to it with TIBTalk, and connect TIBTalk to Spike2; after 
that you can pretty much ignore the TIBTalk program. However 
in situations where there is a communications or TIB problem, 
messages describing the problem will be displayed in the 
remainder of the TIBTalk window. 

TIBTalk is a very simple program so there is very little that you 
can do with it; all the setup and sampling is controlled by 
Spike2. There are however a few menu commands available for 
use within TIBTalk: 

Use this command or the  toolbar button to cause the TIB to 
re-scan for connected sensors and update the device status 
according to what it finds. The TIB firmware currently does not 
automatically detect changes in the sensors available, so you 
will need to use this command after you plug in or disconnect 
any sensors. 

TIBTalk 
commands 

File > Rescan TIB 
sensors 
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Use this command to 
view and edit the settings 
used by TIBTalk to 
connect to Spike2 and to 
a TIB. The dialog 
displays two editable fields: the Spike2 server machine name 
and the TIB rotary switch number: 

This sets the name of the machine on the local network where 
TIBTalk will look for Spike2 and the master network pipe used 
to set up a talker connection. Leave this field blank if you want 
TIBTalk to look for Spike2 on the local machine (the one on 
which TIBTalk is running) or enter the case-sensitive name of 
the Spike2 machine. 

This sets the TIB number (set by the rotary switch on the back 
of the TIB) that will be looked for when opening a TIB. Set the 
rotary switch number to −1 to allow any TIB to be opened, or 
enter 0 to 15 to set the required TIB number, which will cause 
TIBTalk to refuse to open any TIBs with the wrong rotary 
switch position. The TIB rotary switch positions are labelled 0 
to 9 then A to F, A to F corresponding to numbers 10 to 15. 
You should generally only need to enter a number other than −1 
when you have more than one TIB connected to a PC. 

Both of these settings can also be automatically set using 
command line options (detailed in Appendix 1), which are often 
preferable once you have determined which settings you need. 

Use this command when the TIB is connected to cause the 
yellow activity LED to flash for five seconds, either as a test of 
the TIB connection or to make sure that you are connected to 
the correct TIB. 

Use this command to close any open connections and exit 
TIBTalk. 

Use this command to copy all the text in the TIBTalk window to 
the Windows clipboard. 

Use this command to remove all the non-status text from the 
TIBTalk window. 

File > Connection 
settings... 

Spike2 server 
machine name 

TIB rotary 
switch number 

File > Flash activity 
LED 

File > Exit 

Edit > Copy 

Edit > Clear 
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You may wish to make use of more than one TIB at a time. 
This can be done very easily. You can connect up to 16 TIBs to 
a single PC and, if necessary, make use of multiple PCs to 
extend this still further. 

Firstly, each TIB must have a different unit number set using 
the rotary switch on the TIB rear panel. There are 16 rotary 
switch positions, numbered in hexadecimal, 0 to F (0 to 15 in 
decimal numbers). 

The TIBTalk program can only connect to a single TIB so you 
will have to run multiple copies of TIBTalk, one per TIB. You 
will also have to tell each copy which TIB to connect-to, using 
the File menu Connection settings dialog or a command-line 
parameter as detailed in Appendix 1 of this manual. So, for 
example, if you want this copy of TIBTalk to connect to a TIB 
with unit number 3 you would select switch number 3 in the 
dialog or use the \n3 command line parameter. The easiest way 
to set up command line parameters is to edit a shortcut to 
TIBTalk as described in Appendix 1. That way you can have 
one shortcut for each TIB that you wish to use. 

Note that the TIB will append its unit number (if not zero) onto 
the talker name so as to uniquely identify itself to Spike2. So, if 
you change a TIB unit number, Spike2 will see it as being a 
different talker, and you will have to edit any sampling 
configurations that used the TIB under its previous talker name. 

Using multiple 
TIBs 
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This document is not and cannot be anything like a complete 
introduction to using Spike2, or even a complete coverage of all 
the things you can do with a TIB connection and the data 
generated by a TIB. That is well beyond the scope of this 
document, which is much more of a ‘Using a TIB’ manual 
aimed at an experienced Spike2 user. For users new to Spike2, 
we mention all the talker-specific aspects of the program and 
point you in useful directions. This, plus the Spike2 help, 
should get you a long way, but there is no substitute for being 
(or becoming) familiar with the Spike2 software. 

Spike2 generally treats talkers as just an alternate source of data 
to be logged, but it also provides a little extra functionality to 
help manage talkers. If you look in the Sample menu you will 
see a menu item Talkers, and if you move the mouse over it you 
will see a list of all the talkers that this copy of Spike2 knows 
about. Spike2 maintains a simple database of all the talkers that 
it has ever been connected to, mainly so that you can add talker-
generated channels to a sampling configuration without the 
talker actually being connected to Spike2 at that time. (In the 
same way, you can set up channels from a 1401 without 
actually having a 1401 present at the time.) The list shows 
talkers by name, with an exclamation mark appended to the 
names of those that are not currently connected. 

Move and hold the mouse pointer over a talker in the list and 
you will be offered various commands that can be used with 
that talker, the commands available are: 

Using the TIB 
with Spike2 
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This command provides a small window holding general talker 
information, thus:  

 
The information shown includes the maximum number of talker 
channels available, the TIB interface specification version being 
used, the TIB description and the configuration mechanism 
being used. 

This command, only enabled if the talker is currently 
connected, will cause Spike2 to close the talker connection. 
This does not achieve much when TIBTalk is providing the 
talker connection since it will automatically re-connect after 5 
seconds. 

This command, only enabled if the talker is not currently 
connected, will cause Spike2 to delete all of the information 
about that talker from its internal database. 

 Configuring the sampling of data from the TIB is not done 
within TIBTalk; it is done within the standard sampling 
configuration dialog provided in Spike2. TIBTalk simply 
provides a list of available TIB channels to Spike2 along with 
some other information, and the sampling configuration dialog 
within Spike2 then allows you to add channels provided by the 
TIB to the standard channels collected using the 1401, a serial 
line or simply entered by the user. 

Info ... 

Disconnect 

Forget 

Configuring 
sampling 
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At the bottom of the Channels section of 
the Spike2 sampling configuration 
dialog there is a New button which is 
used to add a new channel to the 
sampling configuration. Immediately to 
the right of this there is a button with a 
downwards-pointing arrow. That gives you a list of data 
channel types that can be sampled using the 1401, plus, at the 
bottom, a list of available talkers, both connected and not. 

Selecting a talker gives you a talker channel setup dialog where 
you can select which talker channel you want to use, and set 
various channel parameters: 

 

The Channel selector chooses which channel in the data file 
will be generated by the talker information, while the Item 
selector is used to choose from the available channels from the 
talker in question. The other items are mostly self-explanatory 
(and are mostly not editable by the user) but the Configure 
MPU9250 button at the bottom is of special interest. 

This button, which is only available when the TIB and TIBTalk 
are connected to Spike2, is used to configure various aspects of 
the TIB data generation from within Spike2. This is done using 
a dialog generated by Spike2, using information supplied by the 
TIB. 
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The first four fields available in the 
dialog shown (for an MPU9250 TIB) 
are device-specific and documented 
with the MPU9250 sensor details; the 
last two fields set up triggered-start 
information. 

For all TIB sensor devices where a 
triggered start is possible, the talker configuration dialog will 
show two standard parameters at the bottom which are used to 
control this option: 

This checkbox selects a triggered start to sampling, if set. If you 
use a triggered sampling start it is very important that a suitable 
trigger pulse is fed to the TIB trigger input, otherwise no TIB 
data will be generated. 

This sets the time within the sampling at which a trigger signal 
will be provided to the TIB. It is assumed that this trigger signal 
will normally be a rising TTL pulse generated using a 1401 
digital output. Set this value to the time in milliseconds at 
which the rising edge of the TTL pulse is generated. It is very 
important that this value is set correctly if you are using a 
triggered start, otherwise all of the TIB data that is collected 
will be mis-timed. 

The TIB configuration parameters which you select will be held 
within the Spike2 sampling configuration and are used to set up 
the TIB any time you sample using that configuration. 

Use triggered start 

Trigger time (ms) 
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Sampling using data from a TIB or any other talker is much like 
normal Spike2 sampling; you create a new data file or click on 
Sample Now and the new data file is created with all the 
channels needed. When you press Start sampling begins and 
continues until you stop. The TIB data appears in the growing 
data file in much the same way as any other data, so you get a 
display that looks like this. 

 
An ordinary waveform channel is shown at the bottom, above 
which are data from two of the three MPU9250 accelerometer 
axes, then two gyroscope axes and the staircase-like, slower 
magnetometer data. Note that the baseline level for the upper 
accelerometer channel is about 1, rather than 0 as in the other. 
This is because it is showing the Z axis which registers Earth’s 
gravity field. 

If the TIB data does not appear in Spike2 and the yellow LED 
on the TIB rear panel is flashing, the TIB is waiting for a 
trigger pulse from the 1401 before it begins to produce data. 
Check that the TIB Trigger in BNC is connected to a suitable 
1401 digital output, and that this digital output is set up to 
generate a suitable (rising edge) pulse. Check that the time of 
the trigger pulse is set correctly in the TIB configuration. 

Sampling TIB 
data with Spike2 

Troubleshooting 
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The maximum data sampling rate for a TIB will vary with the 
sensor device used, but in all cases there will be a rate above 
which reliable sampling without data loss cannot be achieved. 

At higher sampling rates, depending upon the sensor device and 
the connected PC, data loss may occur due to USB buffer 
overflows or missed interrupts. Regardless of the cause, if data 
loss occurs the TIB will flash the red Error LED on the back of 
the TIB box and notify TIBTalk. TIBTalk will display an error 
message in the text window and also pass the notification onto 
Spike2, which will save it as a sampling note. If the data loss is 
sufficiently great (currently, above 1% of the total data points) 
the TIB will report a sampling failure to TIBTalk (and Spike2) 
and cease to generate data. 

If you are using sample rates close to the maximum suggested 
for your sensor device it is advisable to check that you can 
sample at that rate without losing data since the maximum rate 
achievable may vary according to your PC and the sensor 
device configuration. 

We cannot cover all aspects of using TIB data here, but there is 
one particular aspect that should be mentioned: this is the 
slightly special nature of the real marker data that is often 
created by the TIB. A real marker channel consists of a 
sequence of items, each item holding its time, four marker 
codes (which are unused and set to zero) and a number of 
floating-point values. 

When real marker data is drawn as a waveform as in the display 
above, only one of the available floating-point values is used 
for the drawing. So to display more of the data you have to first 
duplicate the original real marker channel and then use the 
channel draw mode dialog to select which of the floating-point 
values is to be shown in the duplicate channel. In this way all of 
the data values can be shown. 

Similar effects occur in a number of other situations where only 
one of the available floating-point values can be used. In all 
cases you again select the data you want by supplying an 
appropriate value index. 

Sampling rate 
issues 

Displaying and 
using TIB data 
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Note also that every real marker comes with its own individual 
time value: they are not necessarily exactly equally-spaced in 
time in the way that sampled waveforms are. With most TIB 
data they will not be exactly evenly spaced out in time, both 
because of timing effects within the TIB and because of the 
way that the various sensors work: the data you get will be 
sampled at rates very close to the sampling rate that you 
configured but not necessarily exactly – and the samples will 
jitter in time somewhat. 

It may well be that your analysis requires data values that are 
equally spaced-out in time. There is a mechanism within 
Spike2 to convert real marker data to a waveform at a specified 
rate using linear or cubic spline interpolation. This mechanism 
is one of the many available within the virtual channel system, 
in this case by using a virtual channel expression such as 
RMc(803,1,1). The Spike2 help contains a lot more detail on the 
use of this and other virtual channel expressions. 

Sample timing 
issues 
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The internal TIB firmware is designed so that a wide variety of 
sensor devices can be used, and the behaviour of the TIB both 
as seen from TIBTalk and more importantly from within Spike2 
will vary profoundly according to the type of sensor device that 
is supported. 

Initially the TIB only supported the MPU9250 9-axis position 
sensor and this device has been used as an example throughout 
this document, but support for other devices will be added in 
the future as required (or requested). 

Specific details of the currently supported TIB sensor devices 
follow: 

The MPU9150 or MPU9250 9-axis position sensor provides X, 
Y and Z  accelerometer, gyroscope and magnetometer readings. 
It can be connected to the TIB using the I2C or SPI buses (but 
see below for limitations with SPI). The data sampling rate, 
accelerometer and gyroscope sensitivities, low-pass filters and 
sampling trigger settings can be configured from within Spike2. 

There are three channels of data available from the TIB when 
using a MPU9250 device. Each of these channels holds real 
marker data with three floating point values per data item. Real 
markers are a type of Spike2 data consisting basically of a point 
in time with one or more associated floating-point values. The 
MPU9250 channels available are: 

This has a default channel title of Acc and channel units of g 
(9.81 metres/sec2). There are three floating-point values per 
marker, being the acceleration in the X, Y and Z directions 
respectively. 

This has a default channel title of Gyro and channel units of dps 
(degrees per second). There are three floating-point values per 
marker, being the rotation around the X, Y and Z axes 
respectively. 

This has a default channel title of Mag and channel units of uT 
(microtesla). There are three floating-point values per marker, 
being the magnetic field in the X, Y and Z directions. 

TIB sensor 
device details 

The MPU9250 
and MPU9150 

9-axis position 
sensors 

Acceleration 

Gyroscope 

Magnetometer 
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The SPI bus can be used to connect an MPU9250 sensor to the 
TIB, however because of the complex nature of the MPU it has 
proved impossible to make use of the magnetometer data with 
an SPI connection. Therefore when using an SPI connection the 
magnetometer channel, although present and visible, will be 
permanently marked as unavailable. 

The configuration dialog 
provided when you press 
the Configure MPU9250 
button shown at the bottom 
of the talker channel 
configuration dialog is used 
to configure various aspects 
of the MPU9250 data 
generation from within 
Spike2. These 
configuration parameters 
are stored with the rest of the sampling configuration 
information and are applied to the TIB at the start of sampling. 
The last two parameters are common to all TIB devices that 
support a triggered start to sampling and are described with the 
general configuration information, the first four configuration 
parameters are specific to the MPU9250 sensor device: 

This item sets the data sample rate, in Hz, for all data generated 
by the TIB – different sample rates for different channels are 
not possible. Rates of up to 5000 Hz can be entered, however 
some care is needed when using rates above 1000 Hz; see 
below for information on maximum data rates. Please note that 
although magnetometer data can be generated at high rates, the 
actual magnetometer readings are quite slow (8 to 16 Hz) so 
you will usually see two or more magnetometer readings that 
are the same, giving something of a ‘staircase’ appearance to 
the data. 

This selects between the various accelerometer sensitivities; 
you can choose a full-scale value of 2, 4, 8 or 16 g. The output 
is signed so choosing 4 will allow readings between −4 and 
+4 g. 

SPI interface 
issues – no 

magnetometer 

MPU9250 
configuration 

Sampling rate (Hz) 

Accelerometer full 
scale (g) 
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This selects between the various gyroscope sensitivities; you 
can choose a full-scale value of 250, 500, 1000 or 2000 degrees 
per second. As in the accelerometer, the outputs are signed. 

This selects between the various digital filters available for the 
accelerometer and gyroscope data; you can choose a cut-off 
frequency (the frequency above which the filter removes signal 
components) of Off, 250/460, 184, 92, 41, 20, 10 and 5 Hz. The 
250/460 option uses a 250 Hz cut-off on the gyroscope data and 
a 460 Hz cut-off on the accelerometer data (this is a quirk of the 
internal design of the MPU). 

Note that (again, because of a quirk of the internal design of the 
MPU) the filter setting also affect the maximum rates at which 
the MPU can generate accelerometer and gyroscope data. For 
all filter settings except Off and 250/460, the maximum 
accelerometer and gyroscope data rates are 1 KHz – so if you 
sample at above 1 KHz you will see duplicated readings in your 
data. With the 250/460 filter setting the accelerometer still 
generates data at up to 1 KHz, but gyroscope data is generated 
at up to 8 KHz. With the high-cut filter set to Off the 
accelerometer now generates data at up to 4 KHz, while 
gyroscope data is generated at up to 8 KHz. 

Gyroscope full scale 
(dps) 

High frequency cut 
filter (Hz) 
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The allowed sampling rates for a TIB connected to an 
MPU9250 are 4 to 5000 Hz; however if you want simple, 
reliable, operation you should not exceed 1 KHz, since that is 
generally the maximum rate at which the sensor can generate 
data. With sampling rates higher than this you will usually get 
duplicate points (with most high frequency cut-off filter settings 
– see above) and data loss may occur. 

Running on a fairly fast system, with various amounts of 
sampled TIB data using two MPU9250s, one connected via the 
I2C bus and the other via the SPI bus, the maximum sampling 
rates that could reliably be achieved were: 

Channels Maximum rate 

Acc (I2C) 2000 Hz 

Acc, Gyro (I2C) 1250 Hz 

Acc, Gyro, Mag (I2C)   750 Hz 

Acc (SPI) 5000 Hz 

Acc, Gyro (SPI) 4800 Hz 

Acc (I2C) + Acc (SPI) 1700 Hz 

Acc, Gyro (I2C) + Acc, Gyro (SPI) 1000 Hz 

Acc, Gyro, Mag (I2C) + Acc, Gyro (SPI)   650 Hz 

 

Sampling rate 
limits 
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The LPS22HB sensor provides pressure and temperature 
readings. It can be connected to the TIB using the I2C or the SPI 
bus. The data sampling rate, low-pass filter and sampling 
trigger settings can be configured from within Spike2. 

There are two channels of data available from the TIB when 
using an LPS22HB sensor. Each of these channels holds real 
marker data, with one floating point value per data item. ‘Real 
markers’ are a Spike2 data type consisting of a point in time 
with one or more associated floating-point values. The channels 
available are: 

This has a default channel title of Press and channel units of 
hPa (note that 1 hPa = 1 mbar). The range of possible output 
values runs from about 260 to 1260 hPa. 

This has a default channel title of Temp and channel units of C 
(degrees Celsius). The range of possible output values runs 
from about −40 to +85 degrees C. 

The configuration dialog 
provided when you press 
the Configure LPS22 button, 
shown at the bottom of the 
talker channel configuration 
dialog, is used to configure 
various aspects of the 
LPS22HB data generation 
from within Spike2. These configuration parameters are stored 
with the rest of the sampling configuration information and are 
applied to the TIB at the start of sampling. The last two 
parameters are common to all TIB devices that support a 
triggered start to sampling, but the first two are specific to the 
LPS22HB sensor device: 

This item sets the data sample rate, in Hz, for all data generated 
by the TIB – different sample rates for different channels are 
not possible. You can select between any of the rates supported 
by the LPS22HB: 1, 10, 25, 50 and 75 Hz. 

The LPS22HB 
temperature & 

pressure sensor 

Pressure 

Temperature 

LPS22 
configuration 

Sampling rate (Hz) 
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This selects the digital filtering to be carried out on the pressure 
data. You can select Off to disable the filter, or you can choose 
Rate / 9 or Rate / 20, to select the cut-off frequency relative to 
the selected sampling rate (i.e. the frequency above which the 
filter removes signal components). 

The maximum allowed sampling rate for a TIB connected to an 
LPS22 is 75 Hz. The TIB system is quite fast enough to be able 
to handle data at this rate from the maximum allowed number 
of sensors. 

High frequency cut 
filter (Hz) 

Sampling rate 
limits 
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If you simply run the TIBTalk application by, for example, 
double-clicking on the application .exe file, TIBTalk will run 
with default settings, which means that it connects to TIB 
number zero and looks for Spike2 on the machine on which it 
itself is running. You can set up TIBTalk to use a different TIB 
or look for Spike2 on other machines within a local area 
network. This can be done via the File menu Connection 
settings dialog or by using command-line options. It is often 
convenient to use command-line options once you have got 
things working, since this allows you to set up separate 
shortcuts to TIBTalk which run it using different TIB numbers 
and Spike2 locations. 

The command-line options available with TIBTalk are: 

Connect to TIB number xx. TIB numbers are set using the 
rotary switch on the TIB box. If you don’t use this option 
TIBTalk will connect to the first TIB it finds. 

Look for a copy of Spike2 running on the machine with 
network name or ID ‘name’. 

When TIBTalk runs it parses the command line to find these 
options (which it expects to find separated from each other by 
spaces) and sets itself up accordingly. Machine IDs containing 
a space can be used by enclosing the entire name within double 
quotes thus: /s”machine name”. The order of the options is not 
important, nor is the case of the option character (so -sname or 
-Sname will do the same thing), or the machine name 
(depending upon your network system); but the use of spaces to 
separate the various options is very important. 

The first stage in setting up your command line options is to 
create a suitable shortcut that can be used to run the TIBTalk 
program. The TIBTalk installer will do this if you allow it to, or 
you can do it yourself by finding the tibtalk.exe program, right-
clicking on it and selecting the Send To −> Desktop (Create 
shortcut) option. This will create a suitable shortcut and place it 
on the PC desktop. 

Appendix 1:   
TIBTalk command 

line options 

/nxx or -nxx 

/sname or -sname 

Setting command line 
options in a shortcut 
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You can look at the shortcut settings 
by right-clicking on it and choosing 
the Properties option. You will get a 
tabbed dialog showing various items 
of information about the shortcut. 

The field we are interested in is the 
one called Target. Initially it will 
show just the full path to the TIBTalk 
application including the application 
name, c:\TIBTalk\TIBTalk.exe in the 
example shown. To add command-
line options simply type them at the 
end of the full application path, separating them from the path 
and each other with space characters. 

So if we wanted TIBTalk to connect to TIB number 3 and look 
for Spike2 on networked machine ‘dataAcq’ you would edit the 
Target text so that it was c:\TIBTalk\TIBTalk.exe -n3 -SdataAcq. 
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The TIB is a separate computer system running a program (the 
‘firmware’) held in flash memory. In some circumstances CED 
may send or make available to you an update file to improve the 
TIB performance. This is used to update the TIB firmware. To 
do this follow these steps: 

1. Make sure the TIB is connected to the computer through the 
USB cable, and that TIBTalk is not running or at least not 
connected to the TIB. 

2. Run the teensy.exe loader program supplied on the TIB 
software CD. 

3. The new firmware will be supplied in a file with a .hex 
extension. Use the File > Open HEX file command in 
teensy.exe to open the firmware update file. 

4. You have to press a push button to activate the loader. This 
is located in the same panel as the USB connector, behind a 
hole, on the left. Press it by pushing e.g. a bent paperclip 
through the hole. Teensy.exe should display ‘Programming’ 
followed by ‘Reboot OK’. 

 

5. Use TIBTalk to check that the TIB is working correctly. 

 

Appendix 2:   
Updating the TIB 

firmware 

Program button 
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